ubuntu 16.04 完美运行新版QQ方案

相关软件地址:https://pan.baidu.com/s/1gflTQd9

sudo dpkg --add-architecture i386 
sudo apt-get update
apt-get install lib32z1 lib32ncurses5 libgif7:i386 libgl1-mesa-glx:i386 libssl1.0.0:i386 libgphoto2-6:i386 

1 安装crossover

下载网盘中的 crossover-15_15.0.3-1_all-free.deb

dpkg -i crossover-15_15.0.3-1_all-free.deb

若安装有错误,请尝试

apt-get install -f 自动尝试解依赖问题

2 安装deepin-crossover

下载网盘中的deepin-crossover-helper_1.0deepin0_i386.deb

dpkg -i deepin-crossover-helper_1.0deepin0_i386.deb

若安装有错误,请尝试

apt-get install -f 自动尝试解依赖问题

注: 此处要移除原 deepin-crossover-helper_1.0deepin0_i386.deb 包中对于 libgif4 和 libgnutls-deb0-28 的依赖

移除办法:

mkdir -p extract/DEBIAN

dpkg-deb -x deepin-crossover-helper_1.0deepin0_i386.deb extract/

dpkg-deb -e deepin-crossover-helper_1.0deepin0_i386.deb extract/DEBIAN

修改 extract/DEBIAN/control 文件  在 Depends: 中把libgif4 换成libgif7 和删除  libgnutls-deb0-28

然后 重打包 

mkdir build

dpkg-deb -b extract/ build/

dpkg重新安装移除依赖的安装包


3 安装QQ软件 apps.com.qq.im_8.1.17255deepin11_i386.deb     http://packages.deepin.com/deepin/pool/non-free/a/apps.com.qq.im/  这里也能下载

dpkg -i apps.com.qq.im_8.1.17255deepin11_i386.deb

若安装有错误,请尝试

apt-get install -f 自动尝试解依赖问题

然后在启动器中搜索 crossover  运行 crossover  就会看到QQ出现在容器中了。


附改好依赖关系的deepin-crossover-helper

deepin-crossover-helper.tar

#更新(利用deepin-wine)

网盘地址:https://pan.baidu.com/s/1skX9vVf axkf  (centos运行)

ubuntu只要注释install.sh中的yum和rpm  

换用dpkg

dpkg -i http://packages.deepin.com/deepin/pool/non-free/u/udis86/udis86_1.72-1_i386.deb

发表评论

电子邮件地址不会被公开。 必填项已用*标注